RESOLVED: Service disruption My.TOPdesk

Incident Report for TOPdesk SaaS Status page

Resolved

This incident has been resolved.
Posted May 20, 2025 - 09:25 CEST

Investigating

We are currently experiencing disruptions with one of our services. As a result your My.TOPdesk.com may not be available.

We are aware of the problem and are working on a solution.

If you require support for your TOPdesk environment, please contact TOPdesk Support by phone or via email at support@topdesk.com. Once we have more information, we will update this page.

To inform TOPdesk you are affected by this issue, please visit https://my.topdesk.com/tas/public/ssp/ . Please refer to incident TDR25 05 4864.
Posted May 19, 2025 - 15:26 CEST
This incident affected: Functionality malfunction.